Jump to content
The Dark Mod Forums

Beta Testing 2.09


stgatilov
 Share

Recommended Posts

I noticed this in snowed inn. It looks like some readables, scroll_print_carleton.gui in this case, are cutting off the last line in the xdata string : 

I dont remember this happening before so I think this is a 2.09 bug.

image.thumb.png.21c123cb126f304b3214e6f21d419ac5.png

In game ("lord builder" is missing) 

Untitled-2.thumb.jpg.30fb5d6443da6cd907c3514501f68a95.jpg

  • Like 1
Link to comment
Share on other sites

@stgatilov Main menu music in snowed inn is commented out? Its no longer player the custom music we put in there. I assume this was done while you were reworking the main menu stuff?  What is the proper way for authors to play custom menu music now?

Link to comment
Share on other sites

I have a setup with mirror, visportal, and portal sky leading to a skybox, no issues either on 2.08 or latest 2.09. There's something wrong on your end. Either the mirror setup is wrong (check limitations), or the invisible asset is the issue (brush, model, or its material).

Edited by peter_spy
Link to comment
Share on other sites

I wonder if the mirror might be interacting badly with the ceiling texture I'm using, textures/darkmod/stone/flat/slate01_light: Maybe that shader has something the mirror doesn't like in mixture with a skybox? But since others can't reproduce this one there's no point in dwelling over it, it may be a random map bug that could go away after I tweak things.

Speaking of mirrors: I tried giving the floor on my test map the newly updated textures/washroom/mirror texture. It seems mirror floors work perfectly and without issues :D All characters and entities are reflected, no flickering or clipping or anything, even the player sees theirself! This will be fun to attempt in some cathedrals or other buildings if performance allows.

 

Spoiler

testing_2020-12-29_04_44_41.thumb.jpg.3c6d6cbbe18eda062d675cc9cfdf7538.jpg

 

  • Like 1
Link to comment
Share on other sites

On 12/28/2020 at 11:33 AM, Araneidae said:

I would like to help debug the broken tonemap rendering on my system (my graphics card is old, a ten year old Radeon HD 6950, but the drivers are fully up to date, Fedora 23).  I think we've established that tonemap.fs itself is not introducing the problem, so I imagine the problem is upstream of that at the point where the choice is made whether or not to include tonemap in the processing chain.  I'm afraid I don't know much of the details of OpenGL or the graphics card rendering chain.

Beta 2.09-2 doesn't change anything for me.  I seem to remember that in release 2.08 I could control gamma, but the little preview popup was not available, so I guess that something in 2.09 has broken things.  Indeed, we did a bisect at the start of this chain!

I'm available to assist with tests this week, but will be back at work from Monday in the new year.  Should this conversation be moved to a new thread or a bug report ticket?

Maybe related!

 

https://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-FP16-DCE8-Patches&utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+Phoronix+(Phoronix)

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

@Araneidae You could try to change the color precision to 32 bits (either in the menu or by setting `r_fboColorBits 32` via the console or in your darkmod.cfg. Perhaps we don't have proper detection for 64 bit color buffer support right now, and that messes things up if your card doesn't actually support is, as lowenz's post suggests?

Although I wouldn't really understand how disabling tonemapping could influence this, but who knows...

  • Like 3
Link to comment
Share on other sites

1 hour ago, cabalistic said:

@Araneidae You could try to change the color precision to 32 bits (either in the menu or by setting `r_fboColorBits 32` via the console or in your darkmod.cfg. Perhaps we don't have proper detection for 64 bit color buffer support right now, and that messes things up if your card doesn't actually support is, as lowenz's post suggests?

Although I wouldn't really understand how disabling tonemapping could influence this, but who knows...

Fantastic!  This works!! 😀

The in-game gamma adjustment preview works now as well (this got turned off a release or two ago).

  • Like 2
Link to comment
Share on other sites

On 12/29/2020 at 1:34 AM, kingsal said:

@stgatilov Main menu music in snowed inn is commented out? Its no longer player the custom music we put in there. I assume this was done while you were reworking the main menu stuff?  What is the proper way for authors to play custom menu music now?

I tried to merge only those GUI changes which "surely won't break anything". The big story (about expanding supported ways of customization and removing unsupported from FMs) lives in its own branch, and is delayed for 2.10. So if something broken, it is unintentional. On the other hand, the state of menu GUI is such that touching it slightly in one place often leads to many unrelated things broken, so no surprise 😥

I tried it in 2.08: I see snow animation, but the music is default one.

I think the proper way was and still is uncommenting these lines:

// Uncomment this to override the default menu music
//#undef MM_MENU_SOUND_CMD
//#define MM_MENU_SOUND_CMD "music tdm_mainmenu_background_music;"

// Uncomment this to override the default in-game menu music
//#undef MM_INGAME_MENU_SOUND_CMD
//#define MM_INGAME_MENU_SOUND_CMD "music tdm_objectives;"

In Snowed Inn, these lines are commented...

Link to comment
Share on other sites

No obvious bugs that I can see in the latest 2.09 beta. I just realized the first beta had yet another bug I missed: Ambient music also played at half volume and I could barely hear it... it now plays at the correct intensity again.

This might not be 2.09 specific per say, but I should point out I still keep seeing guards getting stuck in front of doors every once in a while. By stuck I mean they will open the door, but then spin in a circle in front of it even 10 times in a row, before either deciding to walk away or finally go through. I've seen it on more than one FM and with the default door / doorframe models.

Link to comment
Share on other sites

@stgatilovGood to know. We might want to look at FMs that include those files and double check to make sure their custom MM music plays. 
 

@MirceaKitsuneThats a classic TDM bug and as far as I can tell has something to do with door placement and giving the AI enough room to open doors, it could be other things though. It’s probably not a 2.9 bug but I’ll keep and eye out for it. 

Link to comment
Share on other sites

@cabalistic

When "r_useBindlessTextures" is enabled, changing AF during a mission via the menu results in a noticeable freeze when returning to the mission and several stutters or momentary freezes afterwards. I presume this is a byproduct of having to re-initialize the bindless textures?

Restarting fixes the stutter.

Is there a way to make this more graceful or is this a limitation of this feature?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

3 minutes ago, nbohr1more said:

Is there a way to make this more graceful or is this a limitation of this feature?

Please add a bugtracker item for me. When textures are made bindless, texture parameters can no longer be changed for those textures. Changing AF or other parameters with bindless may require recreating the textures.

  • Like 1
Link to comment
Share on other sites

16 minutes ago, cabalistic said:

Please add a bugtracker item for me. When textures are made bindless, texture parameters can no longer be changed for those textures. Changing AF or other parameters with bindless may require recreating the textures.

Done:

https://bugs.thedarkmod.com/view.php?id=5476

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

3 hours ago, kingsal said:

We might want to look at FMs that include those files and double check to make sure their custom MM music plays. 

I just took a look at A Good Neighbor and the custom MM music works fine in 2.09 Beta 2

 

FMs: A Good Neighbor

Link to comment
Share on other sites

Just tested out beta-02, seems to work fine generally but I was messing around with the graphics settings to compare performance and after swapping between maps/stencil shadows there's a visible artifact in the middle of the screen with ambient occlusion enabled.

psDWcvb.jpg

 

AMD RX580 latest drivers.

  • Like 1
Link to comment
Share on other sites

55 minutes ago, dynamix said:

Just tested out beta-02, seems to work fine generally but I was messing around with the graphics settings to compare performance and after swapping between maps/stencil shadows there's a visible artifact in the middle of the screen with ambient occlusion enabled.

psDWcvb.jpg

 

AMD RX580 latest drivers.

When you are using stencil shadows, open the console and type r_usebindlesstextures 1 and hit enter.

What does your image look like?

  • Like 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

15 minutes ago, AluminumHaste said:

When you are using stencil shadows, open the console and type r_usebindlesstextures 1 and hit enter.

What does your image look like?

I did a quick test with this setting, it was already set to 1 for me so I set it to 0 and after a vid_restart I couldn't get it to bug out again.

I didn't try it a lot of times because vid_restart takes a long time for me but seems like it could be related to that setting.

  • Like 1
Link to comment
Share on other sites

Since the beta is an opportunity to fix issues, including ones that existed in 2.08: Is there a chance for alt-tab switching under Linux / KDE to be fixed? I'm referring to this bug:

https://bugs.thedarkmod.com/view.php?id=5293

Alt-tabbing itself works fine. But if you switch to another window, moving the mouse cursor over the TDM window in the background causes it to jump in the middle of the screen. This is normal when the window is focused but shouldn't happen when something else is selected and you only move the cursor across to operate other applications.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • irg

      Watching warmly for The Black Parade, The Broken Goddess and Blood Death Wish Ep.4. Sometimes the best things in life actually are free.
      · 0 replies
    • STiFU

      We are taking our son on his very first holiday trip to see the sea for the first time. 🙂 Will be back in a week.
      · 2 replies
    • Gilkar

      When I was a young man my father was so ignorant I could hardly stand to have him around. As I grew older I was amazed at how much the old man had learned in such a short time.
      · 2 replies
    • jaxa

      RTX 3090 Super, RTX 3070 Ti 16 GB, RTX 2060 12 GB
      https://wccftech.com/nvidia-launching-rtx-3090-super-rtx-3070-ti-16gb-and-rtx-2060-12gb-by-january-2022/
      · 0 replies
    • duzenko

      CPU benchmark time - compiling DarkRadiant (2nd run)
      i5 8600K 6C/6T@4.4GHz DDR4 2x2133MHz 9MB cache
      Parallel builds: 1. 3:57 Parallel builds: 6 (default). 2:28 r5 1600AF 6C/12T@3.3GHz DDR4 1x2666MHz 16 MB cache, temp folder on HDD
      Parallel builds: 1. 5:05 Parallel builds: 4. 2:47 Parallel builds: 6. 2:55 Parallel builds: 12 (default). 2:57
      · 6 replies
×
×
  • Create New...