Jump to content
The Dark Mod Forums

Newbie DarkRadiant Questions


Recommended Posts

Ok, bug #2 then!

I have a couple of stealable paintings in the mission, that are have regular stock skins. When I steal the painting it leaves a black frame, like when you put in invalid skin arg on an object. Since all ripped painting skins are the same, how can I set it to display that when the painting has been stolen?

wYtzOie.jpg

https://imgur.com/wYtzOieDl1T0u3.jpg

I assume this is a failing of the TDM stock assets? It happens in both 2.07 and 2.08.

 

My Fan Missions:

   Series:                                                                           Standalone:

Chronicles of Skulduggery 1: Pearls and Swine                     The Night of Reluctant Benefaction

Chronicles of Skulduggery 2: A Precarious Position              Langhorne Lodge

Chronicles of Skulduggery 3: Sacricide

 

 

 

Link to post
Share on other sites
  • Replies 10k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So I have this gigantic scorpion, it is made out of pendulums bound together. I had an idea about dragging whole thing through a piled up crates (pretending to be stone blocks in a wall), but it looks

I'm just going to make the lute player an undead immortal skeleton called Ralph who is eternally bound to play his lute in the tavern, the residents are used to him now so they just happily co-exist a

Thanks for the advice about the tent, guys. Finally got around to (mostly) fixing it; shadows were indeed the problem.    

Posted Images

@Bienie

I tried it and with the default skin it works fine, though, if I use the skin you are using the same thing happens, it leaves a black rectangle.

Looking further, there must be 2 skins: skin and skin_torn. So somewhere you have to add that _torn skin, that could be "portrait_in_armour_torn" fot it has the same frame.

In the spawnargs there is "replace" that has to do with it, but it's the same with the working and non working skins .. so .. must be done somewhere in the  skin defenition or something ..

I'll go have a look if I can find something.

  • Like 1
Link to post
Share on other sites

@Bienie

 

In line 1222 I added "skin builder02_torn" and that seems to do the trick. I guess you have to do this for all the skins you want to use.

Place the edited file "tdm_decorative_wall.skin" in your skins folder (or create one if you don't have it in your project).

tdm_decorative_wall.skin

 

Next bug plz : )

Edited by STRUNK
  • Like 1
Link to post
Share on other sites
14 minutes ago, STRUNK said:

@Bienie

 

In line 1222 I added "skin builder02_torn" and that seems to do the trick. I guess you have to do this for all the skins you want to use.

Place the edited file "tdm_decorative_wall.skin" in your skins folder (or create one if you don't have it in your project).

tdm_decorative_wall.skin 59.7 kB · 0 downloads

 

Next bug plz : )

Perfect! That did the trick. Added the extra lines for the other painting too. I feel like this is a game bug that should probably be addressed in the stock assets for 2.08 though.

I'll get back when I have a few more bugs ready to be squashed :)

  • Like 2

My Fan Missions:

   Series:                                                                           Standalone:

Chronicles of Skulduggery 1: Pearls and Swine                     The Night of Reluctant Benefaction

Chronicles of Skulduggery 2: A Precarious Position              Langhorne Lodge

Chronicles of Skulduggery 3: Sacricide

 

 

 

Link to post
Share on other sites

Ok, I could only partially solve this one (turns out I had forgotten to set "objective_ent 1" on the items >.<). I have an objective that requires the player to find 5 custom items and place them in a room. They are their own separate class of item I created based off the custom_movable template, so that they would stack properly in the player's inventory. However, when I pick up all five at once and place them all at the same time the objective doesn't tick off as completed. I tried picking up one at a time and dropping it before grabbing the next one, and that seems to work fine... It's very strange, as if having them stack in the inventory somehow changes their properties?

The objective is set up like this:

Let the target entity item_1 be in the location item_drop

Let the target entity item_2 be in the location item_drop

Let the target entity item_3 be in the location item_drop

Let the target entity item_4 be in the location item_drop

Let the target entity item_5 be in the location item_drop

the only flag set is Visible.

Is there a better way to set this objective up? Or can I do some easy change on the items to make it work once they are stacked?

My Fan Missions:

   Series:                                                                           Standalone:

Chronicles of Skulduggery 1: Pearls and Swine                     The Night of Reluctant Benefaction

Chronicles of Skulduggery 2: A Precarious Position              Langhorne Lodge

Chronicles of Skulduggery 3: Sacricide

 

 

 

Link to post
Share on other sites

@Bienie

I have not gotten into objectives yet, but might it be that you should have item_drop_1, item_drop_2 etc. for it to work? (Just a wild guess).

If you can upload a map/test setup with the essential things for this puzzle I could take a look at it and try to understand what is going on. Otherwise you might ask @JackFarmer who has been making a lot of puzzles, and might now the answer.

Link to post
Share on other sites

I've had a similar problem before, and I never thought to ask what was going on, but does anyone know why some of the skins/textures cause this odd glowing effect?

crusher1_2020-05-24_16_26_12.thumb.jpg.f4ad07fe07115f93993746e54ce9c97f.jpg

The above is models/darkmod/decorative/vases/cup_marble with the `cup_marble_shiny` skin. I've had similar problems in the past with some of the statues and a bookshelf skin as well. Is this a bug in the game itself? Just a bad material with a messed up normalmap? 

Link to post
Share on other sites
5 minutes ago, krrg said:

I've had a similar problem before, and I never thought to ask what was going on, but does anyone know why some of the skins/textures cause this odd glowing effect?

crusher1_2020-05-24_16_26_12.thumb.jpg.f4ad07fe07115f93993746e54ce9c97f.jpg

The above is models/darkmod/decorative/vases/cup_marble with the `cup_marble_shiny` skin. I've had similar problems in the past with some of the statues and a bookshelf skin as well. Is this a bug in the game itself? Just a bad material with a messed up normalmap? 

That to me looks like when I forget to do a material and the engine finds the diffuse texture just fine (the texture is in the right place), but doesn't find the material definition and a mtr is required, in that case it renders the model full-bright and semitransparent. But i'm not sure if that is your case. 

Link to post
Share on other sites
46 minutes ago, HMart said:

That to me looks like when I forget to do a material and the engine finds the diffuse texture just fine (the texture is in the right place), but doesn't find the material definition and a mtr is required, in that case it renders the model full-bright and semitransparent. But i'm not sure if that is your case. 

Full-bright and semitransparent describes it perfectly. These are all textures or skins that were defined by the base game, not custom ones by me.

I heard at some point (I don't know if this is true) the assets for the base game got broken out into a bunch of different pk4 files. I wonder if some materials defs got lost in the transition? Just a stab in the dark here, with nothing to guide me but a full-bright semitransparent basin.

Edited by krrg
oops, duplicate words
Link to post
Share on other sites
11 hours ago, STRUNK said:

@Bienie

I have not gotten into objectives yet, but might it be that you should have item_drop_1, item_drop_2 etc. for it to work? (Just a wild guess).

If you can upload a map/test setup with the essential things for this puzzle I could take a look at it and try to understand what is going on. Otherwise you might ask @JackFarmer who has been making a lot of puzzles, and might now the answer.

I don't think it's a problem with the drop location actually, since it works just fine as long as the items did not stack in the players inventory first. It must be that something happens to the item in the stacking process that makes them unable to tick the objective. I tried doing this with two breath potions just to see if they would act the same way and they did. That makes me suspect that this is a limitation of the objectives system in TDM. Perhaps one of our resident coders like @duzenko / @stgatilov / @greebo could shed some light on it? edit: to be clear, referring to this post:

 

10 hours ago, krrg said:

I've had a similar problem before, and I never thought to ask what was going on, but does anyone know why some of the skins/textures cause this odd glowing effect?

crusher1_2020-05-24_16_26_12.thumb.jpg.f4ad07fe07115f93993746e54ce9c97f.jpg

The above is models/darkmod/decorative/vases/cup_marble with the `cup_marble_shiny` skin. I've had similar problems in the past with some of the statues and a bookshelf skin as well. Is this a bug in the game itself? Just a bad material with a messed up normalmap? 

I think this is simply a skin that uses the alabaster material, that has been this weird fullbright and semi-transparent texture for as long as I can remember. I just make sure to not use any of those skins or that texture in my maps.

Edited by Bienie
add link to original problem post

My Fan Missions:

   Series:                                                                           Standalone:

Chronicles of Skulduggery 1: Pearls and Swine                     The Night of Reluctant Benefaction

Chronicles of Skulduggery 2: A Precarious Position              Langhorne Lodge

Chronicles of Skulduggery 3: Sacricide

 

 

 

Link to post
Share on other sites

@krrg

It's the material itself that glows. Somehow there is no real white marble that doesn't glow. The others that say white are all a bit dull in game.

You might try to make other skins available for this model by copying tdm_models_decls01.pk4 >  skins > tdm_decorative.skin , and paste it in the skins folder of your project.

Look there for "skin cup_marble_shiny" Copy that, paste it and name it "skin cup_marble_white" , then you can change textures:

skin cup_marble_shiny
{
model models/darkmod/decorative/vases/cup_marble.ase
model models/darkmod/decorative/vases/cup_stone_large.ase
model models/darkmod/decorative/vases/cup_stone_small.ase

textures/darkmod/stone/natural/dark_dirty	  textures/darkmod/stone/flat/smooth_marble_white01
textures/darkmod/stone/flat/rough_marble_light01  textures/darkmod/stone/flat/smooth_marble_white01
}

//this is the copy renamed and edited
skin cup_marble_white
{
model models/darkmod/decorative/vases/cup_marble.ase

//edit the second texture here
textures/darkmod/stone/flat/rough_marble_light01  textures/darkmod/stone/flat/smooth/marble_white_001
}

To make it easy, here is the tdm_decorative.skin file,  including the part I changed, that you can put in your skins folder

tdm_decorative.skin

  • Like 1
Link to post
Share on other sites
57 minutes ago, Bienie said:

I don't think it's a problem with the drop location actually, since it works just fine as long as the items did not stack in the players inventory first. It must be that something happens to the item in the stacking process that makes them unable to tick the objective. I tried doing this with two breath potions just to see if they would act the same way and they did. That makes me suspect that this is a limitation of the objectives system in TDM. Perhaps one of our resident coders like @duzenko / @stgatilov / @greebo could shed some light on it? edit: to be clear, referring to this post:

 

I think this is simply a skin that uses the alabaster material, that has been this weird fullbright and semi-transparent texture for as long as I can remember. I just make sure to not use any of those skins or that texture in my maps.

I think you want to tag @grayman here

Link to post
Share on other sites

@Bienie I am quite sure that stacking the items is the problem here. Keep in mind, that the items in your inventory are not the original items that you pick up. I.e. an item that you pick up gets removed from the map and is added as an let's call it "inventory item" to the inventory (I learned this, when I tried to target an item in the inventory and used the name of the original item for that). When you drop the item again, the item is spawned with the properties of the item removed beforehand. If I remember correctly items are only stackable in the inventory, when their properties are all the same. So I assume the problem here is that if you want to stack the items, they may not be unique items (i.e. they all need to have the exact same properties). My guess would be that the "item_1", "item_2", etc. names have different numbers after stacking and respawning, resulting in the objective not recognising them as the correct items. You can try the console command "g_showEntityInfo 1" to check the name of the items after dropping them into your target location.

A way to circumvent this, could be to use a script that gets activated by using the item(stack) on the target location. E.g. if this is a box, you don't open the box and let hte player throw stuff inside, but instead make a frobable box and use the "used_action_script" and "used_by_inv_name" spawnargs to start a script that reduces the number in the inventory by one and has an (invisible) counter go up one. When the counter hits a certain number, the script completes the objective. It is less "realistic", because the player does not get to drop the items in himself, but it is less error prone, in my opinion. If you don't have a box (I don't know what your setup looks like), you can add a visual cue, by placing the item in the place the player should put it, but hide it. When the player uses the item from the inventory, it gets removed from the inventory and the hidden item gets shown. This makes it looks like the player placed it there.

Link to post
Share on other sites
13 hours ago, Destined said:

@Bienie I am quite sure that stacking the items is the problem here. Keep in mind, that the items in your inventory are not the original items that you pick up. I.e. an item that you pick up gets removed from the map and is added as an let's call it "inventory item" to the inventory (I learned this, when I tried to target an item in the inventory and used the name of the original item for that). When you drop the item again, the item is spawned with the properties of the item removed beforehand. If I remember correctly items are only stackable in the inventory, when their properties are all the same. So I assume the problem here is that if you want to stack the items, they may not be unique items (i.e. they all need to have the exact same properties). My guess would be that the "item_1", "item_2", etc. names have different numbers after stacking and respawning, resulting in the objective not recognising them as the correct items. You can try the console command "g_showEntityInfo 1" to check the name of the items after dropping them into your target location.

A way to circumvent this, could be to use a script that gets activated by using the item(stack) on the target location. E.g. if this is a box, you don't open the box and let hte player throw stuff inside, but instead make a frobable box and use the "used_action_script" and "used_by_inv_name" spawnargs to start a script that reduces the number in the inventory by one and has an (invisible) counter go up one. When the counter hits a certain number, the script completes the objective. It is less "realistic", because the player does not get to drop the items in himself, but it is less error prone, in my opinion. If you don't have a box (I don't know what your setup looks like), you can add a visual cue, by placing the item in the place the player should put it, but hide it. When the player uses the item from the inventory, it gets removed from the inventory and the hidden item gets shown. This makes it looks like the player placed it there.

Thanks for the tip with g_showEntityInfo 1, I can confirm that is exactly what happened. Once you pick more than one up only the first item retains its properties while the others revert to their "stock" movable form. I guess I will have to rethink that objective and maybe not use stackable items. I don't really feel like writing a whole script for one little side mission.

My Fan Missions:

   Series:                                                                           Standalone:

Chronicles of Skulduggery 1: Pearls and Swine                     The Night of Reluctant Benefaction

Chronicles of Skulduggery 2: A Precarious Position              Langhorne Lodge

Chronicles of Skulduggery 3: Sacricide

 

 

 

Link to post
Share on other sites
On 5/25/2020 at 5:39 AM, STRUNK said:

@krrg

It's the material itself that glows. Somehow there is no real white marble that doesn't glow. The others that say white are all a bit dull in game.

You might try to make other skins available for this model by copying tdm_models_decls01.pk4 >  skins > tdm_decorative.skin , and paste it in the skins folder of your project.

Look there for "skin cup_marble_shiny" Copy that, paste it and name it "skin cup_marble_white" , then you can change textures:


skin cup_marble_shiny
{
model models/darkmod/decorative/vases/cup_marble.ase
model models/darkmod/decorative/vases/cup_stone_large.ase
model models/darkmod/decorative/vases/cup_stone_small.ase

textures/darkmod/stone/natural/dark_dirty	  textures/darkmod/stone/flat/smooth_marble_white01
textures/darkmod/stone/flat/rough_marble_light01  textures/darkmod/stone/flat/smooth_marble_white01
}

//this is the copy renamed and edited
skin cup_marble_white
{
model models/darkmod/decorative/vases/cup_marble.ase

//edit the second texture here
textures/darkmod/stone/flat/rough_marble_light01  textures/darkmod/stone/flat/smooth/marble_white_001
}

To make it easy, here is the tdm_decorative.skin file,  including the part I changed, that you can put in your skins folder

tdm_decorative.skin 22.77 kB · 0 downloads

Unfortunately, not all asset contributors who have joined and left the project understood the need to define "diffusemap" for lit materials or have used

other blend modes to overcome technical challenges in multi-stage materials. Some of these things were done for individual maps where the glow was not

apparent since the texture was in a lit room (for example). I have been meaning to audit this for a few commonly used materials that are clearly fullbright in dark areas...

  • Like 2

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I don't see anything obviously wrong with the textures/darkmod/stone/flat/smooth_marble_white01 or white_shiny materials.  Neither use an additive stage.

Both textures have been around for a decade, so I would assume this is more likely to be a local issue, especially given that it also happened on a bookshelf, which don't traditionally use additive stages either.

 

Link to post
Share on other sites
1 minute ago, nbohr1more said:

Hmm... I wonder if it's the frob stage? Is that object in frob distance?

No, the problem happens well outside of frob distance (and the entity isn't even frobable). 

 

13 minutes ago, Springheel said:

I don't see anything obviously wrong with the textures/darkmod/stone/flat/smooth_marble_white01 or white_shiny materials.  Neither use an additive stage.

Both textures have been around for a decade, so I would assume this is more likely to be a local issue, especially given that it also happened on a bookshelf, which don't traditionally use additive stages either.

 

I was kind of thinking this was a local issue as well, except that I can reproduce this on completely different machines; the first place I noticed this were some problematic bookshelves when I was working on In Danger of Judgment on an old laptop. I'm mapping with a completely different computer now, fresh installation, etc, and still it seems like I have the fullbright problem for a few of these skins.  Let me see if I can find the bookshelf that was giving me problems.

Link to post
Share on other sites

Try putting the textures/darkmod/stone/flat/smooth_marble_white01 texture on a brush and see if you have the same effect.  That would help rule out the skin file or missing texture as the problem.

 

 

 

Link to post
Share on other sites
3 minutes ago, Springheel said:

Try putting the textures/darkmod/stone/flat/smooth_marble_white01 texture on a brush and see if you have the same effect.  That would help rule out the skin file or missing texture as the problem.

crusher1_2020-05-26_19_11_53.thumb.jpg.60ab5bf6ecd2838e671d69681fbca00c.jpg

Not sure what to make of this!

Link to post
Share on other sites

Well, it's not the model or the skin.  Any console warnings about missing textures? 

Link to post
Share on other sites
14 minutes ago, Springheel said:

Well, it's not the model or the skin.  Any console warnings about missing textures? 

Nope, no warnings about it from from what I can see. For what it's worth, this is the map I'm using to repro this. I'd be curious to know what others see when they load this up.

Edit: Even more interesting, is that some sides of the brush have this weirdness going on:crusher1_2020-05-26_19_41_01.thumb.jpg.abc0340a06ad2903e562cfed0110d29c.jpg

bug1.map

Edited by krrg
Link to post
Share on other sites

@Springheel @krrg

I have the same experience with that particular texture, it's lit up. This isn't a problem in a well lit area, but in a darker area it is.

A lit up bookcase I have never seen btw.

Btw textures/darkmod/stone/flat/smooth_marble_white01 is not to be found in the media browser, but you can select is as a shader in the surface inspector when you have this models/darkmod/decorative/vases/cup_marble.ase in the map.

marble.png

textures/darkmod/stone/flat/smooth/marble_white01, that is in the media browser, doesn't glow ...

 

Edited by STRUNK
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...