Jump to content
The Dark Mod Forums

Beta Testing 2.09


Recommended Posts

1 minute ago, AluminumHaste said:

Mirror's working fine for me.

That's weird and makes things complicated then. I don't see how it could be map related unless I'm doing something very unusual, so more likely it's some graphical setting I may have enabled. I'd rather not share my super unfinished map just yet so I'm not sure how I can further help on the mirror bug. I'll think on it in case anything comes to mind.

21 minutes ago, Dragofer said:

The next beta build will have my furniture pack (originally posted here and here)(rev 16045), and a fix for the blue flame elementals.

I love the way that furniture looks! Thank you for another very welcome asset contribution :D

  • Like 1
Link to post
Share on other sites
  • Replies 404
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

The announcement about 2.09 release will come soon. I'd like to thank everyone who took part in this beta phase! With so many people taking part in the beta phase, we can make official releases

Full changelog of 2.09 development. dev15976-8815 Includes all the changes from trunk which did not get into 2.08: * RGTC compression is now used by default. * More work on X-ray view. *

TDM 2.09 is ready for beta test In order to update, you have to use the new tdm_installer this year. Custom mirrors file is not needed any more. Windows 64-bit, Fresh install (slow):

Posted Images

39 minutes ago, AluminumHaste said:

Well this is what I get on my mirror I just set up:

darkmod_2020-12-24_15_13_29.thumb.jpg.6ec180806295f18fbe0a8ca5376522d0.jpg

This is the current 2.09 beta build

Try deleting your darkmod cfg?

Hmmm. Can you try giving the room a window, ideally visible in the mirror (behind it), which leads to an opening textures with portal sky and a sky box? That's the only specific I can think of in my setup that doesn't appear here.

Link to post
Share on other sites
1 hour ago, peter_spy said:

It's been done to death, but seems like it has to be repeated time and time again: don't test engine beta versions with WIPs. Too many variables at play, and quite likely mapper's fault. Find a released mission with a mirror that exhibits the same symptoms, to be on the safe side.

I don't remember any advice regarding this. If my WIP depends on an as-yet-unreleased version of TDM, I can't be waiting for that version to be released before testing my WIP on it (and potentially discovering a problem I should have found before the TDM rev was released).

Perhaps the advice was given in a certain situation in the past, a particular map? A particular TDM version?

 

  • Like 1
Link to post
Share on other sites
6 hours ago, stgatilov said:

I'm really sorry for that.

Don't be. While I still think the default settings for 2.08 were a bit too dark and needed a little more tweaking before being set as the defaults, I kinda went above and beyond with the level of tweaking that most folks would have bothered with. I don't have ADD/ADHD (I think...) but I'm quite fussy about certain things at times, which is why I said it was embarrassing - it's more a reflection on myself than the game. :)

A word of warning, Agent Denton. This was a simulated experience; real LAMs will not be so forgiving.

Link to post
Share on other sites
7 hours ago, duzenko said:

Shadows clipped funny when walking around in Volta 1
]getviewpos
1742.75 3245.4 -859.75   13.5 -43.2 0.0

Most likely that's the old version dmapped with 2.07:

Uninstall the FM, then go to in-game downlowder and get the update, then try again.

Link to post
Share on other sites
10 hours ago, MirceaKitsune said:

New bug found. 2.09 seems to break mirrors... quite literally 😄 Screenshots taken from two different rooms, the map is freshly dmapped with no errors or leaks or other geometric issues visible directly.

It is probably related to sky.

Anyway, could you share your map? At least privately with developers?

Link to post
Share on other sites
7 hours ago, grayman said:

I don't remember any advice regarding this.

That issue comes up repeatedly with every new beta. I'm here roughly since 2.05, and there's always a mapper coming out and complaining something doesn't work on their untested WIP, while it works with thoroughly tested and finished FMs. And it's usually because they forgot something, or their map is a mess. Which is okay, it's a WIP after all. But reporting that as bugs is a waste of developers' time.

7 hours ago, grayman said:

If my WIP depends on an as-yet-unreleased version of TDM

That is a very bad idea in general, switching the tech in the middle of making something. Typically you lock the tech you're working with until you're finished with your project, or you at least wait for the final release before you update. You all work in software development to some degree, right? This is the basics, how is that not a rule of thumb for you?

Link to post
Share on other sites
16 hours ago, MirceaKitsune said:

Hmmm. Can you try giving the room a window, ideally visible in the mirror (behind it), which leads to an opening textures with portal sky and a sky box? That's the only specific I can think of in my setup that doesn't appear here.

darkmod_2020-12-25_08_26_30.thumb.jpg.609e17583ca6f369ef14330df53f521b.jpg

The window even has a visportal set up in it.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites
16 hours ago, MirceaKitsune said:

Hmmm. Can you try giving the room a window, ideally visible in the mirror (behind it), which leads to an opening textures with portal sky and a sky box? That's the only specific I can think of in my setup that doesn't appear here.

Here, try my map see if it also screws up for you.

LightTest.7z

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites
39 minutes ago, AluminumHaste said:

Here, try my map see if it also screws up for you.

LightTest.7z 36.77 kB · 0 downloads

Interesting: I tried it and on this map I'm not getting any issues either, the mirror reflects perfectly fine. So it is something on my map triggering it after all, and it must be 2.09 specific since a few weeks ago it didn't do it and I haven't modified the map since. I'll send the devs a copy of my map file with a getviewpos, let me know who's willing to look into it and I shall PM it.

  • Like 1
Link to post
Share on other sites
14 hours ago, stgatilov said:

Most likely that's the old version dmapped with 2.07:

Uninstall the FM, then go to in-game downlowder and get the update, then try again.

It was downloaded this week :(

...

Another issue with SVN

Volta 2 start objectives show up empty with a console error

image.png.1dce751a999925cfa8ee8dd2bb39cd75.png

Link to post
Share on other sites
31 minutes ago, duzenko said:

It was downloaded this week :(

...

Another issue with SVN

Volta 2 start objectives show up empty with a console error

image.png.1dce751a999925cfa8ee8dd2bb39cd75.png

Try the latest build:

I believe we need to update the mirrors since there was some confusion about this (and remove the bloodgate mirrors that currently cannot get updates due to bandwidth overages).

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I just removed the bloodgate mirrors from both Volta 1 and 2. Now the downloader should only gather files from the primary mirrors.

  • Thanks 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

@duzenko @stgatilov  Right so this is a bug with my package, not the mod. Long story short, before we got the updated briefing video stuff, we had to do some finnicky stuff with GUIs to get video to work right. 

This is related to the cinematic end bug that shows the blank parchment 4535

 

In my current FM package (the one with the parchment bug from the mirrors), I have a custom mainmenu_briefing_video.gui "Xd" out so it doesnt load. However if I include it, I don't get the cinematic end bug. What do I need to do here? This is strange because the only difference between the two is in my custom gui DOES NOT include the onNamedEvent CinematicEnd lines. 

Link to post
Share on other sites
On 12/25/2020 at 2:37 AM, MirceaKitsune said:

I don't see how this can be a mapper fault since everything else works fine and my map has no leaks, only mirrors are broken and not rendering the ceiling of the room.

I'd recommend looking at any FM that uses the mirror shader and seeing if the same issue occurs. I remember there are quite a few FM's that have mirrors in bathrooms, sadly no name by memory but I'm sure one can be found.

I tried to test AC2, which has mirrors, and its mirrors are buggy. They have been buggy for quite some time, also in 2.09 they are buggy in slightly different way due to r_useClipPlaneCulling.

So I digged deeper, and realized that the mirror that has the problem (near -115.41 415 1157.25) is created with a brush having many mirror-textured sides. The engine only renders mirrored effect for one mirror surface (per material stage), so it just chooses a random surface out of 5-6 available and it happens to be the wrong one.

The question is: should I put a warning into dmap to complain about brushes who have several sides of same mirror texture? I guess it applies to all textures with mirrorRenderMap and remoteRenderMap keywords.

As for @MirceaKitsune problem, I suggest opening the .map file in text editor and checking that "mirror" only occurs once per every different mirror in your FM, and never on several sides of same brush.

Link to post
Share on other sites
24 minutes ago, stgatilov said:

The engine only renders mirrored effect for one mirror surface (per material stage), so it just chooses a random surface out of 5-6 available and it happens to be the wrong one.

Is there a reason for that behaviour? Otherwise it would be more logical to allow to have brushes with several mirrored sides and render them all as mirrors.

FM's: Builder Roads, Old Habits, Old Habits Rebuild

Mapping and Scripting: Apples and Peaches

Sculptris Models and Tutorials: Obsttortes Models

My wiki articles: Obstipedia

Texture Blending in DR: DR ASE Blend Exporter

Link to post
Share on other sites
16 minutes ago, Obsttorte said:

Is there a reason for that behaviour? Otherwise it would be more logical to allow to have brushes with several mirrored sides and render them all as mirrors.

Performance is a good enough reason.

Imagine the engine would render all five faces. That would double the number of frontend runs, and will significantly decrease performance. And if there is no diagnostic, then nobody knows the reason.

As for correctness, I have no idea. You can always duplicate material and and apply different material on the other side. To be honest, I believe all sort of mirror effects are hacks, better don't stretch it too much 😁

  • Like 1
Link to post
Share on other sites
5 hours ago, stgatilov said:

I tried to test AC2, which has mirrors, and its mirrors are buggy. They have been buggy for quite some time, also in 2.09 they are buggy in slightly different way due to r_useClipPlaneCulling.

So I digged deeper, and realized that the mirror that has the problem (near -115.41 415 1157.25) is created with a brush having many mirror-textured sides. The engine only renders mirrored effect for one mirror surface (per material stage), so it just chooses a random surface out of 5-6 available and it happens to be the wrong one.

The question is: should I put a warning into dmap to complain about brushes who have several sides of same mirror texture? I guess it applies to all textures with mirrorRenderMap and remoteRenderMap keywords.

Great catch, and that's a proper regression. Such warning would be appreciated.

IIRC, mirrors were never great back in Doom3 either, and they still need to be applied on brushes (not models).

Link to post
Share on other sites
On 12/24/2020 at 11:41 AM, MirceaKitsune said:

I remember seeing it a few times but forgot exactly where. The only example I remember now is from today while playing an old FM called The Creeps: You should hear it with the double doors on the floor leading downwards when trying to open or pick them from outside (tiny FM so easy to find).

Created issue 5462.

Is it true that you had such issues with doors which a) are horizontal, and b) have no handles ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...