Jump to content
The Dark Mod Forums

Beta testing 2.10


stgatilov
 Share

Recommended Posts

10 minutes ago, Araneidae said:

@Dragofer, I expect you're right.  Not sure what to do with my reports then, it's a bit tricky to reproduce.  It seems to happen when the alert stimulus is very brief, I either bump up against a guard or am briefly glimpsed; I guess there's then a disconnect between the guard's own alert status and the global alert status.  Last time I tested this I checked with `tdm_ai_showalert 1` and indeed the guard was on high alert, and the global status was zero.

Already sounds useful - have you opened a ticket on bugs.thedarkmod.com for this? Thats the best place to keep such information.

Link to comment
Share on other sites

13 hours ago, Araneidae said:

I have a large pool of downloaded missions ... but I can't just drop them into my fms directory because the downloader won't recognises them as already downloaded.  I see that I have a "downloaded_version" entry in missions.tdminfo, but to my dismay there's no checksum or anything like that to validate.

I'd really rather not re-download 900MB of missions.  Is there any way to check which of my missions are correctly up to date and just manually copy them across?

I normally just copy the whole fms folder from the old version to the new one after a fresh install. If i don't do the a fresh install, i copy the whole TDM folder and then just update to the desired version.

I had some missions refusing to update properly or getting stuck in an update loop some TDM versions ago.
But i deleted the offender's folders and after the redownload of just that few missions, everything was fine again.

Link to comment
Share on other sites

5 hours ago, Abusimplea said:

I normally just copy the whole fms folder from the old version to the new one after a fresh install. If i don't do the a fresh install, i copy the whole TDM folder and then just update to the desired version.

The problem is, I want the in-game downloader to show me the missions I haven't got ... not all of them.  Also, I'd like to check I've got up to date versions of the missions I have, and the conventions for this seem to have changed a lot over the years.

Apologies, this is wandering way off topic!

@Dragofer, ok, reported as issue 5888.

Edited by Araneidae
  • Like 2
Link to comment
Share on other sites

Something is screwy with decal rendering again. Example: "textures/darkmod/decals/dirt/scattered_dirt01" in the model "models/darkmod/junk/scattered_papers01_leaning.lwo" disappears from view when you look at it at a right angle ie. when you stand over the papers. I noticed a similar thing while beta testing Iris but I don't know if that's the same decal. Another decal to complain about is "textures/darkmod/decals/dirt/scorch_flatbottom", that simply doesn't show from either side even when placed in the middle of a room. This decal has "sort 1" and the former has "decal_macro" in the defs, to shortcut you some info if you need it. I'm on Nvidia drivers.

  • Like 1

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

Oh good! I see the sparkly lines are gone, and frame rates seems marginally better too.

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

On 1/24/2022 at 8:45 AM, Araneidae said:

The problem is, I want the in-game downloader to show me the missions I haven't got ... not all of them.

(Afaik) you need the missions.tdminfo from the old install. You can edit the new file to make changes and the mission downloader will use that. You can check the darkmod.txt for the version of your missions (if version is supplied to that file).

Link to comment
Share on other sites

Looks like something has happened to volumetric lighting in beta05. It was working fine in beta04 but after I upgraded to 05, it stopped working. I went back to 04 just to verify it was working, and it was. I verified I'm using Map shadows (r_shadows "2") and my r_volumetricSamples is "8".

Did something break in beta05? Anybody else seeing this?

  • Like 1
Link to comment
Share on other sites

1 hour ago, joebarnin said:

Looks like something has happened to volumetric lighting in beta05. It was working fine in beta04 but after I upgraded to 05, it stopped working. I went back to 04 just to verify it was working, and it was. I verified I'm using Map shadows (r_shadows "2") and my r_volumetricSamples is "8".

Did something break in beta05? Anybody else seeing this?

Are you using the entity spawnarg ? ( previously it was a material def property )

https://wiki.thedarkmod.com/index.php?title=Light_Properties#Volumetric_light

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

17 minutes ago, joebarnin said:

Yep, on the light I have:

volumetric_light=1

volumetric_dust=.002

volumetric_noshadows=-1

Worked fine in beta04, but not in beta05.

Thank you!

If you increase the dust value does it become visible?

Please post your Darkmod.cfg

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Just now, joebarnin said:

I increased dust to 0.2 and all the way to 1.0 - still not visible. Here's my darkmode.cfg:

Darkmod.cfg 14.39 kB · 0 downloads

seta r_shadows "1" is stencil shadows

Volumetric lights requires r_shadows "2" ( Shadow Maps )

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Sorry, I keep going back and forth between beta04 and beta05. So this last time I ended up with the default cfg (r_shadows "1"). That's the file I attached first. I realized this mistake and set Shadow Maps ( r_shadows "2"), and it still doesn't work (current attached file).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 4 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...