Jump to content
The Dark Mod Forums

Newbie DarkRadiant Questions


demagogue

Recommended Posts

Finally got it working. It turns out that all the used_by stuff is a bust. There doesn't seem to be any way to stop it frobbing multiple times in rapid succession.

 

A better way is to make the receptacle an atdm:frobable_base and target it to a callscript that runs the following:

float objects_in_receptacle = 0;

void receptacle_script() {
    string curinv = $player1.getCurInvCategory();
    if(curinv!="Marbles") {return;}    //check to make sure you've selected the things that will
                                      //go into the receptacle. If not, go back
    $player1.changeInvItemCount("Glass Marble", "Marbles", -1);   //remove a marble from inventory
    $objects_in_receptacle+=1;                                    //increment count in bucket
    // DO ANYTHING ELSE THAT HAPPENS WHEN YOU DROP A MARBLE IN THE BUCKET
    return;
}

 

  • Like 2
  • Thanks 1

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

Just thought I'd drop in an oddity about the trigger_sequencer entity:

Its targets are evaluated in lexicographical, rather than numerical, order. That is, target10 will fire before target2.

  • Like 1
  • Thanks 2

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

OK, I'm tearing my hair out over an end-mission conversation cutscene. I'm activating a script along these lines

 

void gameover() {
    $badguy_atdm_teleport.activate($player1);
    sys.fadeTo('0 0 0', 1, 2);
    sys.wait(2);
    $gameover_cam.activate($player1);
    sys.fadeTo('0 0 0', 0, 2);
    sys.wait(2);
    $start_gloatconvo.activate($player1);

    sys.wait(7);
    $player1.missionFailed();
    return;
}

Basically I teleport the badguy into position, fade to black, transfer the view to the camera, fade back in, and begin his conversation. Unfortunately, he just stands there and won't do his monologue. Sometimes he even freezes completely, not even doing his idle movements. If I comment out the $gameover_cam.activate and noclip there, the conversation does work correctly.

What am I doing wrong?

 

camera_suppress.mapcamera_suppress.script

Here's a minimal example of the problem. Press the red button, the camera activates but the guy's conversation won't play. The green button triggers a script that's identical except that the camera is commented out- and his conversation does trigger.

Edited by thebigh
typo

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

19 hours ago, thebigh said:

OK, I'm tearing my hair out over an end-mission conversation cutscene. I'm activating a script along these lines

 

void gameover() {
    $badguy_atdm_teleport.activate($player1);
    sys.fadeTo('0 0 0', 1, 2);
    sys.wait(2);
    $gameover_cam.activate($player1);
    sys.fadeTo('0 0 0', 0, 2);
    sys.wait(2);
    $start_gloatconvo.activate($player1);

    sys.wait(7);
    $player1.missionFailed();
    return;
}

Basically I teleport the badguy into position, fade to black, transfer the view to the camera, fade back in, and begin his conversation. Unfortunately, he just stands there and won't do his monologue. Sometimes he even freezes completely, not even doing his idle movements. If I comment out the $gameover_cam.activate and noclip there, the conversation does work correctly.

What am I doing wrong?

 

camera_suppress.map 14.85 kB · 0 downloads camera_suppress.script 609 B · 0 downloads

Here's a minimal example of the problem. Press the red button, the camera activates but the guy's conversation won't play. The green button triggers a script that's identical except that the camera is commented out- and his conversation does trigger.

Give the AI the property

cinematic - 1

 

 

  • Thanks 1
Link to comment
Share on other sites

Aha! Not sure how I missed that...

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

  • 2 weeks later...

Hello TDM-ers.

I am encountering an issue where textures seem to partially disappear.  I tried searching the forums, but, I don't know what to search for.

The missing textures are a worldspawn brush acting as a roof with {for now} flat iron texture.  There are other worldspawn brushes right below to create an attic ceiling with roof framework board texture.

These gaps appeared a few edits ago.  I can't "undo" to get back before whatever edit did this.  The gaps are only visible during play and are not visible during editing.  Closing and reopening DR and TDM do not fix anything.

Some of the brushes overlap in areas behind the play area but I have never seen an issue doing that.

The attached image has the effect I am now seeing.

Ideas on where to start debugging this?

Very much appreciated.

Clint

TextureLoss001.jpg

Edited by cvlw
Link to comment
Share on other sites

On 9/9/2023 at 11:37 AM, AluminumHaste said:

Usually this is due to not snapping your brushes to the grid.

Ok thanks.  Yeah this roof build seems to defy the grid by its shape, so will look at that and see if I can create it better with the grid in mind.

What is the minimum grid?  Should I avoid the fractional grids and  go with 1 or above?

EDIT>>>  Thanks AluminumHate.  I think this is the exact advice I needed.  I selected each roof brush and hit control-G to align to grid (grid 1 in this case), and it corrected all of the missing textures in game play.  I now need to address roof brushes better as there is now a lot of misalignment.  I will try and keep gridding in mind going forward.

Clint

Edited by cvlw
Link to comment
Share on other sites

50 minutes ago, cvlw said:

Ok thanks.  Yeah this roof build seems to defy the grid by its shape, so will look at that and see if I can create it better with the grid in mind.

What is the minimum grid?  Should I avoid the fractional grids and  go with 1 or above?

EDIT>>>  Thanks AluminumHate.  I think this is the exact advice I needed.  I selected each roof brush and hit control-G to align to grid (grid 1 in this case), and it corrected all of the missing textures in game play.  I now need to address roof brushes better as there is now a lot of misalignment.  I will try and keep gridding in mind going forward.

Clint

Grid 1 is fiddly, prone to vertex drifts. Honestly, that grid size is something I would use to make details on a door. A sloping roof should be snapped to grid8

  • Like 1
  • Thanks 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

Yes, and anything under 1 I tend to use only to nudge decals off the surface they're Z-fighting with

  • Like 1

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

  • 2 weeks later...

Here's another question (the last for this mission, I'm sure)!

I'm using info_location for the ambient sounds, which works quite nicely, but I don't really want the sound to loop endlessly. I tried adding s_looping 0 to one of the info_locations, but the sound still loops there. I also tried that on the global atdm:location_settings, but it still loops. Is it bugged or is it just me?

Link to comment
Share on other sites

You might just be better off triggering a speaker when you want it played. I could be wrong, but I don't think the location system ambients work like how you want them to

Edited by Amadeus
  • Thanks 1
Link to comment
Share on other sites

On 8/13/2023 at 7:11 PM, thebigh said:

It would also be possible to use a script to move a speaker.

Say your river is running straight west-east. Put the river noise speaker in the river somewhere. Then set up a trigger-timer to fire every 0.1 of a second and target it to a callscript. The script will then get the player's X-coordinate and set the speaker's X-coordinate to that value. In this way the speaker will always be level with the player and it should sound as though the river noise is coming directly from the river.

Great idea. I just added this to my upcoming mission. chatGPT helped me with the script.  Works like a charm.

vector playerPosition;
vector riversoundPosition;

void sound_follow(entity zone)  // have river sound speaker ($river_sound) follow the player along the river when in the yard
{
	playerPosition = $player1.getOrigin();
	riversoundPosition = $river_sound.getOrigin();
	riversoundPosition_y = playerPosition_y;  // river runs north-south, only need to change y
	$river_sound.setOrigin(riversoundPosition); 
	sys.wait(0.2);
	thread sound_follow($player1);
}

void kill_sound_follow(entity zone) // stop river sound following player when they leave the yard 
{
	sys.killthread("sound_follow");
}

 

Edited by grodenglaive
  • Like 1
Link to comment
Share on other sites

Hello again TDMers.

I am using Text entities to make notes on the map of things I need to do.  However, I constantly need to manually add the TEXT property every time I add one.  The Text is the basic reason I am adding these things.

Is there a way to make the TEXT property show up by default when I create the Text entity?  Maybe also the Force property (defaulted to 0) and playerOriented (defaulted to 0)?  I use these three properties regularly, but they are not present by default.

Appreciated.

Clint

 

Edited by cvlw
Link to comment
Share on other sites

 

Quote

Is there a way to make the TEXT property show up by default when I create the Text entity?

yes but this requires that you make a copy of the original .def file where the text entity is defined, that I personally don't know where in TDM (in Doom 3 is in misc.def) and make a def folder for your own mission where you put the .def file copy (your copy will override the original def file, when your mission is played).

see the new "text" default var

entityDef text {
	"editor_color"			"1 1 0"
	"editor_mins"			"-4 -4 -4"
	"editor_maxs"			"4 4 4"
	"editor_showangle"				"1"
	"editor_rotatable"				"1"

	"editor_usage"					"Used to display debug text in a level"
	"editor_var text"				"text to print"
	"editor_bool force"				"if set to 1 prints always otherwise only in developer mode"
	"editor_bool playerOriented" 	"if set to 1 text always faces the player"
	"editor_var scale"				"text scale"
	
	"scale" 				"0.25"
	"text"				"default text shown for all text entites"

	"spawnclass"			"idTextEntity"
}

 

Edited by HMart
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • taffernicus

      i am so euphoric to see new FMs keep coming out and I am keen to try it out in my leisure time, then suddenly my PC is spouting a couple of S.M.A.R.T errors...
      tbf i cannot afford myself to miss my network emulator image file&progress, important ebooks, hyper-v checkpoint & hyper-v export and the precious thief & TDM gamesaves. Don't fall yourself into & lay your hands on crappy SSD
       
      · 1 reply
    • OrbWeaver

      Does anyone actually use the Normalise button in the Surface inspector? Even after looking at the code I'm not quite sure what it's for.
      · 7 replies
    • Ansome

      Turns out my 15th anniversary mission idea has already been done once or twice before! I've been beaten to the punch once again, but I suppose that's to be expected when there's over 170 FMs out there, eh? I'm not complaining though, I love learning new tricks and taking inspiration from past FMs. Best of luck on your own fan missions!
      · 4 replies
    • The Black Arrow

      I wanna play Doom 3, but fhDoom has much better features than dhewm3, yet fhDoom is old, outdated and probably not supported. Damn!
      Makes me think that TDM engine for Doom 3 itself would actually be perfect.
      · 6 replies
    • Petike the Taffer

      Maybe a bit of advice ? In the FM series I'm preparing, the two main characters have the given names Toby and Agnes (it's the protagonist and deuteragonist, respectively), I've been toying with the idea of giving them family names as well, since many of the FM series have named protagonists who have surnames. Toby's from a family who were usually farriers, though he eventually wound up working as a cobbler (this serves as a daylight "front" for his night time thieving). Would it make sense if the man's popularly accepted family name was Farrier ? It's an existing, though less common English surname, and it directly refers to the profession practiced by his relatives. Your suggestions ?
      · 9 replies
×
×
  • Create New...