Jump to content
The Dark Mod Forums

Issues in 2.08 final


Recommended Posts

I've been noticing that sometimes, instead of a sound playing, I get sort of a weird electronic "BOOP". A few examples I can remember off the top of my head are hitting an oil lamp with a blackjack, walking through a curtain, and most recently,  the latest update for the mission Volta 1: The Stone, where it goes "BOOP" once on the menu screen instead of playing music. This issue never happened before I updated to 2.08.

Link to post
Share on other sites
  • Replies 117
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Found the culprit! The G-Sync.....   Disabling it problem got solved in TDM too!

Okay, so I found another issue which may be connected to 2.08 or some specific missions: Sometimes for notes a font is used that is very pixelated and barely readable. See this example from Shadows of

Only after the savegame loading+ESC, then the situation goes normal !   And yes, for who's asking "What map is that!?!?!?".....it's a nice surprise coming to you from our good PranQster (wit

Posted Images

If I remember correctly, that BOOP sound is played when a sound hasn't been found. However, if I start up Volta 1, I don't get that BOOP sound, there is just no background music at all. Console says "gigagooga_loop9 couldn't be loaded, using default".

EDIT: @kingsal it's a bug in your FM. The referenced soundshader is defined nowhere in your package and it's no core asset.

Link to post
Share on other sites

@STiFU Hm, that’s very weird because I didn’t originally release that mission with that particular ambient. 
 

I’ll have a look at this and fix it today. 
 

The boop  plays when a sound file is missing. There is a way to turn that off- I’ll try to find the console command. I though it was off by default for release builds though. 

Link to post
Share on other sites

The command to stop the boop from happening is "s_playDefaultSound" "0"

@JehauriYou can bring up the console with the  ~ button and type the command above (without quotes) and press enter. This should disable the boop sound. 

Do you remember which mission you heard the boop while walking through a curtain?

Link to post
Share on other sites

Unfortunately, I don't remember which mission had the curtain. I think it was in front of a toilet, possibly one that you can use to infiltrate via the sewers, and it was probably either a mission from the Chronicles of Skulduggery series or Hidden Hands series, but I can't remember for sure.

Knowing how to turn off the boop sound is good, but is there anything I can do to fix the actual issue? I'm still not sure what causes the sounds to be missing. If it's fan mission authors making an oversight, why did it never happen until 2.08? Is it possible my install glitched and I'm just missing the actual sound files for a few things?

Link to post
Share on other sites
8 hours ago, Jehauri said:

Unfortunately, I don't remember which mission had the curtain. I think it was in front of a toilet, possibly one that you can use to infiltrate via the sewers, and it was probably either a mission from the Chronicles of Skulduggery series or Hidden Hands series, but I can't remember for sure.

Knowing how to turn off the boop sound is good, but is there anything I can do to fix the actual issue? I'm still not sure what causes the sounds to be missing. If it's fan mission authors making an oversight, why did it never happen until 2.08? Is it possible my install glitched and I'm just missing the actual sound files for a few things?

It is usually an issue with the FM or the core Mod. I mean you could try to redownload all that stuff, but I doubt it'll fix it.

Link to post
Share on other sites

Black textures :

Cleaning Up the Neighborhood

cleaning-2020-08-07-19-58-14.jpgcleaning-2020-08-07-20-03-06.jpg

Perilous Refuge

peril-2020-08-07-20-16-30.jpg peril-2020-08-07-20-17-56.jpg peril-2020-08-07-20-20-38.jpg peril-2020-08-07-20-22-25.jpg

Edited by Apiai
Link to post
Share on other sites

The black lamps are unfortunately a bug, not an install/asset problem. 2.08 seems to read skin files differently so now it matters when there are non-standard characters in file paths, most prominently the hyphen in /non-extinguishable/ for lamps.

Link to post
Share on other sites

I've run (ran?) the installer again, it says "TDM installation is up to date"

FYI : I use v2.08 32bits version.

Link to post
Share on other sites
2 hours ago, Apiai said:

Yes, because I've got an "old" computer with W7-32bits.

If it can run TDM, the hardware most likely supports 64bit operating systems. You could try upgrading to Linux or updating to Windows 10.

Link to post
Share on other sites

When I go underwater, it gets very dark/black. Can't see anything. At least not in the first map I've tried -- Volta 2: Cauldron. Has happened in all instances of water I've gone into so far. Looks quite inviting pre-plunge... but then I go into it and it is impossible to navigate around. Do you think this is an issue with TDM 2.08, or the map?

 

volta2-1.thumb.jpg.7902169cd3e495a5f9400113df35cf7c.jpg

 

volta2-2.thumb.jpg.834e90314215ca5fe90db17d7d0ac869.jpg

 

EDIT: Ahh, I see it was reported on Page #1 of the thread. And to reply to stgatilov, you're right, I'm afraid it's an issue...

On 7/10/2020 at 10:54 AM, stgatilov said:

Perhaps we should change something.
It is expected that gamma/brightness looks different, but this sounds like a problem.

Edited by Darkness_Falls
Link to post
Share on other sites
25 minutes ago, Darkness_Falls said:

When I go underwater, it gets very dark/black. Can't see anything.
EDIT: Ahh, I see it was reported on Page #1 of the thread. And to reply to stgatilov, you're right, I'm afraid it's an issue...

Gamma/brightness settings have no effect underwater. That's why it is so dark.

Link to post
Share on other sites

Note that r_ambientGamma has gameplay impact - it increases overall brightness and thus also player visibility. So setting that value high is not a good long-term fix. The issue is on the roadmap for 2.09.

  • Like 1
Link to post
Share on other sites
3 hours ago, cabalistic said:

Note that r_ambientGamma has gameplay impact - it increases overall brightness and thus also player visibility.

I think it does not.

  • Like 1
Link to post
Share on other sites
35 minutes ago, stgatilov said:

I think it does not.

It does. r_ambientGamma directly affects the outcome of the ambient lighting stage, which is also applied to lightgem calculation. It's very easy to test - go to a dark corner, then increase ambient gamma and watch the lightgem get brighter...

Edit: actually, it's fine in 2.08, so this is a regression in 2.09. I'll look into it.

  • Like 2
Link to post
Share on other sites
17 hours ago, esme said:

Hi @Darkness_Falls & @stgatilov I edited the Darkmod.cfg to change r_ambientGamma, that seemed to sort it out

Thanks esme! Sadly, it's not working well for me. No matter what I try with that, the above-water environment gets bleached out bright whenever I adjust things to be able to see underwater. I can't find any happy-mediums settings to use. I've tried several different values for that field in the .cfg file while also messing with the Brightness and Gamma settings in the game menu. No luck :(

Is too bad, too, as I always enjoyed TDM's underwater view/effect in past years. And I really can't progress on this mission without going under water; I'm sure several FMs are that way... so, for me at least, it's a showstopper type of bug so far.

To be honest, gamma/brightness, in general has been a bit of an issue/concern for me at least through the last couple TDM releases... but I don't remember under water being this bad before. It's usually just been "could be better" or not  being able to play during the day because I couldn't crank gamma/brightness up high enough. (Keep in mind, I don't know that I played much in 2.07 and have a new PC as of mid- or late-last year. But even on my old PC, TDM gamma/brightness was never my absolute friend ;) )

Wonder what the issue is? I tried disabling options one-by-one in the menu, too (bloom, shadow implementation, shadow quality, soft shadows, color precision, ambient occlusion, multi-core enhancement, anti-aliasing, texture anisotropy, etc.), as I have most settings maxed out, but nothing fixed the blackness under water.

Regarding proper ambience, it really should look like my 3rd screenshot here. 1st screenshot is how bright I have to make it with the .cfg change and gamma/brightness sliders in order to see under water in a reasonable manner (2nd screenshot)...

volta2-3.jpg.6fc0b28607f22ff49cf5a703335f8c6a.jpg

 

volta2-4.jpg.ee374feb2d61355c51c9f2fd8f17339b.jpg

 

volta2-6.jpg.bdac56bfca6baf68082a4b3c12b9bf2d.jpg

Hope this can be resolved soon, as I'm sad I can't play TDM :(

 

Edited by Darkness_Falls
Link to post
Share on other sites

I don|t know if this a problem of 2.08 or of my setup because I tested an audio update, but I often hear a beep sound where I guess there shouldn't be one. Like when starting or ending a mission, last experienced with Volta 1...

  • Like 1
Link to post
Share on other sites
7 minutes ago, wesp5 said:

I don|t know if this a problem of 2.08 or of my setup because I tested an audio update, but I often hear a beep sound where I guess there shouldn't be one. Like when starting or ending a mission, last experienced with Volta 1...

This is talked about above on Page 3 of this thread. Jehauri mentions a "boop" sound. There are a few replies worth checking out, but here's one:

On 8/5/2020 at 10:47 AM, kingsal said:

The boop  plays when a sound file is missing. There is a way to turn that off- I’ll try to find the console command. I though it was off by default for release builds though. 

Link to post
Share on other sites

As noted in that thread, the console command to turn off the boop is "s_playDefaultSound"  "0". I thought it was off by default but I guess not.

@Darkness_Falls The underwater darkness is because of the map. I used a custom shader there that darkens the underwater parts.  Its intentional, but maybe its a little too dark if you arent able to see. You can always use your lantern "L" key underwater to help. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...