Jump to content
The Dark Mod Forums

Newbie DarkRadiant Questions


demagogue

Recommended Posts

The most likely cause imo is that the objects are further from the map origin, the larger coordinates leading to minor rounding errors.

  • Thanks 1
Link to comment
Share on other sites

9 hours ago, joebarnin said:

I converted the brush to a func_static, that seems to resolve the problem. I thought I had already tried that, but I guess not. I'll keep experimenting, but it looks like it might be as simple as that.

This also happens to me regularly when I create cylinders with small diameters. The item from the project below is very close to the world origin.

image.png.e90a33e1ff0eb64f617137bc5c5a22dc.png

Edited by JackFarmer
Link to comment
Share on other sites

1 hour ago, JackFarmer said:

This also happens to me regularly when I create cylinders with small diameters. The item from the project below is very close to the world origin.

image.png.e90a33e1ff0eb64f617137bc5c5a22dc.png

Do you mean the edges on the cylinder?  You can round those out just by fiddling with the Patch Tesselation in the patch inspector:

image.png.d153612087e1a6fdd0e2a3d4db6363a9.png

  • Thanks 2
Link to comment
Share on other sites

I'm having a bit of trouble getting skins to work. I've got the following in my skins file:

skin eyeball_brown
{
	model "models/darkmod/heir/eyeball.lwo"

	"models/darkmod/props/textures/eyeball_blue"    "models/darkmod/props/textures/eyeball_brown"
}

This skin shows up in the skin selector but it does not replace the former texture with the latter. All the files are where they're supposed to be.

 

What am I doing wrong?

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

Are you sure that's the materials' names? Usually materials that use textures from the props folder dont have paths in their names. You can look them up in the DR media browser or in the model chooser for that model.

Link to comment
Share on other sites

It doesn't seem to matter what I name the materials. I can remove the path names and call them something more sensible like this:

 

//   heir.mtr

eyeball
{
       
	diffusemap	textures/darkmod/heir/eyeball_blue
	
    //....
}

eyeball_brown
{
	   
	diffusemap	textures/darkmod/heir/eyeball_brown

    //.....    
}

And then refer to the materials under those names in the skin file:

 

// heir.skin

skin eyeball_brown
{
	model models/darkmod/heir/eyeball.lwo

	eyeball eyeball_brown
}

but it still refuses to substitute the second material for the first. I can select the skin, but that has no effect. The original material works fine, with the texture showing up correctly. I'm obviously overlooking something but not sure what.

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

Instead of that try this to see if it works, it does on my end

skins/bathroom/Tube01a_waterclean
{
	model	"models/mapobjects/washroom/bathtub_oldA.lwo"

	"textures/common/nodraw"	"textures/water_source/Water_clear"
}

change the stuff for your own model/materials of course :) 

Edited by HMart
Link to comment
Share on other sites

7 hours ago, thebigh said:

All the files are where they're supposed to be.

Are all the files and folders lowercase? Probably.

I was wondering something. TDM's core skin files all have "" around file paths, but you don't see this in material files and on the skins wiki it is also not really mentioned as necessary. Whould it matter to include or not include them?

 

Link to comment
Share on other sites

IMO there's some benefits to using "" around paths, one it permits you to put spaces in your paths (thou I don't recommend that at all), second it breaks your paths into easier strings, for the text parser to read/deal with, it also help us visually distinguish what's is what better.

They aren't a rule you can ignore them but imo using them maybe decreases the probably of parsing errors. 

About lower case, I'm not sure but unless you are comparing strings, I don't think the parser itself cares about the case of character in a string. Thou because of portability to linux and other OS's idSoftware recommended, no spaces in folder names and no higher case letters in a path, the engine even has a warning message just for that. But like you see above, even I forget that sometimes, is why I have plenty of warnings about non portable paths in the console! :P  

Link to comment
Share on other sites

I ended up deleting and re-creating the problematic prop, and its material and skin entries. As far as I can tell I did everything the same as before, but now it mysteriously works. Well, mostly. The skin viewer in DR still won't preview the new skin, but it works in-game and that's good enough for me.

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                                                                                                  The House of deLisle                                                                                                  

                              

Link to comment
Share on other sites

I'm having an odd issue placing a key in DR. If I place it on a desk, the character can't frob it, but I can put it on top of a cupboard or on the floor and it works fine. I'm not sure what's going on with the desk. I tried two different ones from the prefabs (desk1 and desk 2b) and I still run into the same problem. Strangely, there is a candlestick on the prefab desk and I can pick that up just fine, but not the key.

Link to comment
Share on other sites

9 minutes ago, grodenglaive said:

I'm having an odd issue placing a key in DR. If I place it on a desk, the character can't frob it, but I can put it on top of a cupboard or on the floor and it works fine. I'm not sure what's going on with the desk. I tried two different ones from the prefabs (desk1 and desk 2b) and I still run into the same problem. Strangely, there is a candlestick on the prefab desk and I can pick that up just fine, but not the key.

Hm...can you export a small selection of the area in question with the "Export selection as map" from DR and post it here?

Link to comment
Share on other sites

20 minutes ago, grodenglaive said:

hm...works as it should on my end:

https://streamable.com/vttr71

 

You could try a workaround called "frob-booster" greyman introduced to me a few years back, though I am not sure about the exact steps anymore:

1. Cover the key with a clip box a little larger than the key.

2. Convert the clip box into func_static and give it the property frobable - 1

3. I am not sure about the next step: either bind the key to the clip box or the clip box to the key...and then try again (edit: bind the box to the key)

 

 

Edited by JackFarmer
Link to comment
Share on other sites

I figured it out! I had deleted a previous desk in that location, but left behind the drawer collision boxes. I had the collision filter on, so I didn't see them (and also they didn't get selected for the test map I exported). 😀

Even though the boxes don't overlap with the position of the key, it was still interfering some how. Anyway, I deleted those and now I can frob the key.

 

 

Screenshot 2023-04-06 112855.jpg

  • Like 2
Link to comment
Share on other sites

1 hour ago, DeTeEff said:

Is it possible to add more vertexes to a NURBS spline curve? Standard is three, but I would like to litter my like a patch so I can curve it as I want without the need to splice them/glue several together...

If I understand correctly, if you use the v key to enter vertex edit mode this should be possible.

Background:

https://bugs.thedarkmod.com/view.php?id=6167

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • taffernicus

      i am so euphoric to see new FMs keep coming out and I am keen to try it out in my leisure time, then suddenly my PC is spouting a couple of S.M.A.R.T errors...
      tbf i cannot afford myself to miss my network emulator image file&progress, important ebooks, hyper-v checkpoint & hyper-v export and the precious thief & TDM gamesaves. Don't fall yourself into & lay your hands on crappy SSD
       
      · 1 reply
    • OrbWeaver

      Does anyone actually use the Normalise button in the Surface inspector? Even after looking at the code I'm not quite sure what it's for.
      · 7 replies
    • Ansome

      Turns out my 15th anniversary mission idea has already been done once or twice before! I've been beaten to the punch once again, but I suppose that's to be expected when there's over 170 FMs out there, eh? I'm not complaining though, I love learning new tricks and taking inspiration from past FMs. Best of luck on your own fan missions!
      · 4 replies
    • The Black Arrow

      I wanna play Doom 3, but fhDoom has much better features than dhewm3, yet fhDoom is old, outdated and probably not supported. Damn!
      Makes me think that TDM engine for Doom 3 itself would actually be perfect.
      · 6 replies
    • Petike the Taffer

      Maybe a bit of advice ? In the FM series I'm preparing, the two main characters have the given names Toby and Agnes (it's the protagonist and deuteragonist, respectively), I've been toying with the idea of giving them family names as well, since many of the FM series have named protagonists who have surnames. Toby's from a family who were usually farriers, though he eventually wound up working as a cobbler (this serves as a daylight "front" for his night time thieving). Would it make sense if the man's popularly accepted family name was Farrier ? It's an existing, though less common English surname, and it directly refers to the profession practiced by his relatives. Your suggestions ?
      · 9 replies
×
×
  • Create New...